Severe VirginMedia broadband issues in the Dorking area

For anyone becoming more and more frustrated with the VirginMedia broadband service, particularly in the Dorking area, I wanted to give an update on my own experience, and that of those of my clients who are with VirginMedia.

On Thursday morning I started work at 9am and found I had no internet connection. I am on the VirginMedia 30Mb package and although I have never managed to get more than 17Mb it is normally a stable connection. It was down until approximately 11.30am which was, frustratingly, the exact moment I managed to get through to someone in support.

I had already rebooted my router several times before phoning, but was advised to do it again, even though I told them I now had a working connection. The “support” engineer also rebooted it remotely and told me I didn’t have a problem. I asked how I knew it wouldn’t immediately come back and was told it wouldn’t.

Ever since, the connection has been unusable. Although the connection is up, and speed test sites such as www.broadbandspeedchecker.co.uk report I am getting the speed I am used to (17Mb), pages will not load unless I stop and refresh the page many many times. A perfect example of a page that is difficult to load is any page in Virgin’s own support forum. The fact that speed tests work ok allow the Virgin support personnel to test the speed of the link and inform you that all is ok and refuse to do anything more for you.

I have spoken to another support agent, but received the same “reading from a script” level of support. She informed me eventually that an engineer would be sent out, but that she’d had to put “broken cable” on the form because she didn’t understand my long and detailed description of the issue. She didn’t tell me when I should expect the engineer though, so I don’t expect them any time soon.

I have tried all the tricks at my disposal, such as using alternate DNS servers (OpenDNS and Google among others) with no improvement.

So far, in the 4 days since the problem started I have spoken to 4 clients who are experiencing the same issue, but I am prepared to say that it will be affecting all VirginMedia broadband customers in the area. A look at the forums shows people with similar problems in Leatherhead, Fetcham and other areas.

I have begun to express my frustration on Twitter (@HolmPC), Facebook and here on this blog in the hope that if enough people complain, VirginMedia will be forced to acknowledge and fix the problem. I also expect that such a low level of service should entitle customers to some sort of refund, at least for the period of time the connection has been unfit for purpose.

Are you seeing the same thing? Please let me know, and express your frustration to Virgin too!

Update: 12:52 on Monday 28th
I have just called VirginMedia again and received a recorded message saying they have identified the problem and hope to have it fixed by 4:40pm. Let’s wait and see.

Update: 8:36 on Wednesday 30th
A day and a few hours later than originally promised, but it seems to have been fixed around 8pm yesterday. If you are still having problems please let me know, but either way give 150 a call and insist on compensation for your down time.

Posted in Uncategorized.

5 Comments

  1. Experiencing exact same problem in Leatherhead area. Scripted support no use. I had done all they asked beforehand anyway. Support person said they would call back yesterday. Still waiting. Pre-recorded message at 1920 today says problem fixed but it is most definately not. Fed up with VM. Will be switching to BT infinity at earliest chance.

  2. I am based in the Fetcham area and have experienced similar problems, initially a few days ago web pages would be slow to load but the internet was usable, things took a turn for the worse yesterday and today with the service proving un usable. I spoke to Virgin (Bangladesh) on Sunday who booked in an engineer for Tues (tomorrow). I recieved an automated call this afternoon saying the fault was being dealt with and should be sorted by 4.40. It is now 9.42 and the service is still grim, if you dial 150 from a Virgin land line the message states that the problem should now be fixed?

  3. I’m in KT23, Tue 29th 00:45, and service is still crap. “specialist technician” due to visit tomorrow. Virgin helpdesk in Bangalore or wherever was next to useless, apart from arranging a visit by someone who’ll be able to see the rubbish service they’re serving up.
    Good luck.

  4. Mr Virgin is on his way to see me. He’s already told me it’s his 12th broadband call today and there’s a national problem. But he has to make the call and confirm it because it’s on his worksheet.

  5. Thanks for everyone’s comments. I was promised a visit by an engineer, but the support didn’t give me a time and needless to say they never turned up. The aim of support does seem to just be to make you go away and buy time so that the problem will either get fixed or go away of it’s own accord. Sorry to hear everyone else was having problems too, and it’s always good to gather as many examples of people experiencing the same problem so VM have to take notice.
    Does everyone now feel that the problem has been fixed? Are you at least up to the reliability levels you had before Thursday?
    Oh, and don’t forget to call Virgin on 150 and insist on compensation for your down time. Even the £10 they offered me is better than nothing.

Leave a Reply

Your email address will not be published. Required fields are marked *